Вопрос по информатике:
Составить задачу по паскалю абс
Назовем слово А следом слова В, если В можно составтиь из букв, входящих в А, при этом каждая буква в В может использоватся не чаще, чем она астречается в А. Например, слово "УЛЬТРАМАРИН" - след слова "ЛАНИТА" или "МИР", но не является следом слова "МЕРА" (оно содержит букву "Е", которой нет в слове "УЛЬТРАМАРИН") или "РИММА" (буква "М" здесь встречается двва раза, а вслове "УЛЬТРАМАРИН" - один раз).
Задаются два слова Х и У. Следует проверить, является ли слово У следом слова Х. Извествно, что оба слова содержат прописные буквы латинского алфавита и имеют длину до 30 симвлов.
Формат ввода:
Х
У
Формат вывода:
Сообщение "YES", если слово У является следом слова Х
Сообщение "NO", если слово не является следом слова Х
- 22.12.2017 10:44
- Информатика
- remove_red_eye 6617
- thumb_up 24
Ответы и объяснения 1
begin
readln(x);
readln(y);
l:=length(x);
k:=0;
for i:=1 to l do
if pos(x[i],y)>0 then
begin
delete(y,pos(x[i],y),1);
k:=k+1;
end;
if k=l then writeln('YES') else writeln('NO');
end.
Пример:
MAMAPROGRAMMA
YES
- 23.12.2017 23:06
- thumb_up 46
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.