Вопрос по информатике:
В классе 20 учеников писали диктант по русскому.Написать программу подсчета кол-ва 2 3 4 5 получивших за диктант(писать через массив)
- 12.03.2018 14:11
- Информатика
- remove_red_eye 14166
- thumb_up 49
Ответы и объяснения 1
Program diktant;
var a: array[1..20] of integer;
i,a,b,c,d: integer;
begin
for i:=1 to 20 do
begin
write ('Введите оценку ',i,'-го ученика: ');
readln (a[i]);
end;
for i:=1 to 20 do
begin
case a[i] of
2: a:=a+1;
3: b:=b+1;
4: c:=c+1;
5: d:=d+1;
end;
end;
writeln ('Количество учеников, получивших 2, равно ',a,', 3 - ',b,', 4 - ',c,', 5 - ',d);
end.
- 13.03.2018 21:29
- thumb_up 17
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.