Вопрос по информатике:
Даю 23 балла!
Напишите программу, которая в последовательности натуральных чисел определяет количество нечетных чисел, кратных 3. Программа получает на вход натуральные числа через клавиатуру, количество введённых чисел неизвестно, последовательность чисел заканчивается числом 0 (0 – признак окончания ввода, не входит в последовательность). Количество чисел не превышает 1000. Введённые числа по модулю не превышают 30 000. Программа должна вывести два число: длину последовательности (завершающий 0 не учитывается) и количество нечетных чисел, кратных 3.
- 21.07.2018 17:02
- Информатика
- remove_red_eye 13813
- thumb_up 43
Ответы и объяснения 1
var i,k,x:longint;
begin
k:=0;
for i:=1 to 1000 do;
begin
read (x);
if (x mod 2 0) and (x mod 3 = 0) then k:=k+1;
if x=0 then begin
break
end;
end;
write (i-1,' ',k);
end.
- 22.07.2018 17:04
- thumb_up 28
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.