Вопрос по информатике:
Дан массив из тридцати элементов. Проверьте, есть ли среди элементов стоящих на четных местах такой, значение которого лежит в интервале от a до b.
Если такой элемент существует - напишите YES, иначе напишите NO.
Формат входных данных
На первой строке через пробел записаны целые числа Arri (|Arri|≤1000) — элементы массива.
На второй строке записано целые положительные числа a и b.
Формат выходных данных
Строка, содержащая запись YES либо NO
- 09.02.2015 03:24
- Информатика
- remove_red_eye 9118
- thumb_up 34
Ответы и объяснения 1
Var
i, x, y: integer;
a: array[1..30]of integer;
begin
readln(x, y);
for i := 1 to 30 do read(a[i]);
for i := 1 to 30 do if (i mod 2 = 0) and (a[i] >= x) and (a[i] <= y) then
begin
write('YES');
exit;
end;
write('NO');
end.
- 01.01.1970 00:00
- thumb_up 21
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.