Вопрос по информатике:
Напишите программу, которая считывает из файла строки - каждую строку в отдельную строковую переменную, затем печатает их и их количество.
Язык С++
- 09.02.2015 02:19
- Информатика
- remove_red_eye 18401
- thumb_up 48
Ответы и объяснения 1
#include
#include
#include
#include
using namespace std;
#define FILENAME "input.txt"
int main() {
ifstream fin(FILENAME);
vector lines;
string s;
while (getline(fin, s))
lines.push_back(s);
cout << "Lines:\n";
for (int i = 0; i < lines.size(); i++)
cout << lines[i] << endl;
cout << "Count of lines: " << lines.size() << endl;
return 0;
}
- 01.01.1970 00:00
- thumb_up 30
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.