Вопрос по информатике:
1. Составить программу ,которая определяет ,сколько раз в предложении встречается слово "дом".
2. Составить программу ,вычисляющую длину самого короткого слова в предложении из трёх слов ,разделённых пробелами.
Паскаль
- 26.09.2018 00:23
- Информатика
- remove_red_eye 12522
- thumb_up 17
Ответы и объяснения 1
Var S:string;
i,k:integer;
Begin
Write('Введите строку: ');ReadLn(S);
LowerCase(S);
k:=0;
For i:= 1 to S.Length-2 do
if S[i] = 'д' then
if S[i+1] = 'о' then
if S[i+2] = 'м' then
k:=k+1;
WriteLn(k)
End.
Var
S:string;
i,d1,d2,d3:integer;
Begin
WriteLn('Введите строку:');
ReadLn(S);
i:=0;
Repeat
i+=1
Until S[i] = ' ';
d1:=i-1;
Repeat
i+=1
Until S[i] = ' ';
d2:=i-d1-2;
Repeat
i+=1
Until i = S.Length;
d3:=i-d2-d1-2;
if d3 < d1 then d1:=d3;
if d2 < d1 then d1:=d2;
WriteLn(d1)
End.
- 26.09.2018 06:47
- thumb_up 32
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.