Вопрос по информатике:
Дан массив из n чисел. Составить программу для вычисления суммы элементов массива, имеющих чётные индексы. Паскаль
- 27.11.2016 00:49
- Информатика
- remove_red_eye 18734
- thumb_up 14
Ответы и объяснения 1
// Внимание! Если программа не работает, обновите версию!
begin
var a:=ArrRandom(ReadInteger('n='),-99,99); a.Println;
Write('Сумма элементов с четными индексами ',
a.Where((x,i)->i.IsOdd).Sum)
end.
Пример
n= 13
81 6 -34 -33 -13 86 -14 -49 -28 -20 -93 5 -62
Сумма элементов с четными индексами -5
- 27.11.2016 15:06
- thumb_up 45
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.