Вопрос по информатике:
10 класс Напишите программу в паскале, которая в последовательности натуральных чисел находит среднее арифметическое трёхзначных чисел или сообщает, что таких чисел нет (выводит NO). Программа получает на вход натуральные числа, количество введённых чисел неизвестно, последовательность чисел заканчивается числом 0 (0 undefined признак окончания ввода, не входит в последовательность). Количество чисел не превышает 100. Введённые числа не превышают 300.
Списанные программы не засчитываю, я тоже умею пользоваться поисковиками
- 21.07.2018 17:33
- Информатика
- remove_red_eye 14452
- thumb_up 46
Ответы и объяснения 2
// Внимание! Если программа не работает, обновите версию!
begin
(var k,var s):=(0,0);
var m:integer;
repeat
Read(m);
if (m>99) and (m<1000) then begin s+=m; k+=1 end;
until m=0;
if k>0 then Writeln(s/k) else Writeln('NO')
end.
Пример
25
6234
193
-46
274
35
0
233.5
- 22.07.2018 12:37
- thumb_up 30
const n=100;
var a: array [1..n] of integer;
i,sum,k: integer;
begin
for i:=1 to n do
begin
write('введите ',i,' элемент: ');
readln(a[i]);
if (a[i]=0) or (a[i]>300) then break;
if (a[i]99) then
begin
k:=k+1;
sum:=sum+a[i];
end;
end;
if k0 then writeln('ср. ариф: ',sum/k)
else writeln('no');
end.
- 23.07.2018 15:21
- thumb_up 28
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.