Вопрос по информатике:
Помогите составить программу по паскалю. Надо из 33 переменных( 33 буквы из русского алфавита) составить слово "Вечность". Кажется надо использовать массив.
- 25.12.2016 05:42
- Информатика
- remove_red_eye 9548
- thumb_up 32
Ответы и объяснения 2
{$R-,$Q-}{Отключаем RE}
{Смысл использовать массив, когда есть строчки?}
const s='АБВГДЕЁЖЗИЙКЛМНОПРСТУФХЦЧШЩЪЫЬЭЮЯ;
var i:integer;Sfor,send:string;
Begin
sfor:='ВЕЧНОСТЬ';
send:='';
for i:=1 to length(sfor) do send:=send+s[ord(sfor[i])-ord('А')];
writeln(send);
end.
- 26.12.2016 20:50
- thumb_up 31
Var
s,st1:string;
begin
s:='абвгдеёжзийклмнопрстуфхцчшщъыьэюя';
st1:=copy(s,3,1)+copy(s,6,1)+copy(s,25,1)+copy(s,15,1)+copy(s,16,1)+copy(s,19,1)+copy(s,20,1)+copy(s,30,1);
writeln(st1);
end.
- 27.12.2016 20:30
- thumb_up 23
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.