Вопрос по информатике:
Нужно заполнить массив из 10 элементов случайными числами в интервале [-10..10] и найти в нем 2 максимальных элемента и их номера . написать программу на языке паскаль
- 21.05.2017 16:26
- Информатика
- remove_red_eye 16200
- thumb_up 45
Ответы и объяснения 1
Const
n=10;var
a:array[1..n]of integer;
i,max1,max2,im1,im2:integer;
begin for i:=1 to n do
begin
a[i]:=random(21)-10;
write(a[i]:4);
end;
max1:=a[1];im1:=1;
for i:=1 to n do
if a[i]>max1 then
begin
max1:=a[i];
im1:=i;
end;
for i:=1 to n do
if (a[i]<=max1)and(iim1)and(a[i]>max2)then
begin
max2:=a[i];
im2:=i;
end;
writeln;
writeln('i: ',im1,' max1: ', max1,' i: ',im2,' max2: ',max2);
end.
- 22.05.2017 17:34
- thumb_up 30
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.