Вопрос по информатике:
На с++ и несложно, пожалуйста
Подсчитайте за один проход массива, сколько его элементов равны максимальному элементу.
Входные данные
На вход программе сначала подается значение n100 — количество элементов в массиве. В следующей строке входных данных расположены сами элементы массива — целые числа, по модулю не превосходящие 30 000.
Выходные данные
Выдайте количество искомых элементов массива.
Примеры
входные данные
8
4 3 5 2 5 1 3 5
выходные данные
3
- 22.12.2015 19:10
- Информатика
- remove_red_eye 10216
- thumb_up 48
Ответы и объяснения 2
#include
using namespace std;
int main(){
int n,maks,schetchik;
cin >>n;
if(n<=100){
int a[n];
for(int i=0;i cin >> a[i]; if (a[i]>-30000 && a[i]<30000){ if(i==0){maks=a[i]; schetchik =1;}; if (i!=0 && maks == a[i]) {schetchik +=1;}; if (maks } } cout << schetchik; } }
- 23.12.2015 20:26
- thumb_up 39
#include
int main()
{
int *arr, size, max = -30000, nMax = 0;
std::cin >> size;
arr = new int[size];
for (int i = 0; i < size; i++)
{
std::cin >> arr[i];
if (arr[i] > max)
max = arr[i], nMax = 1;
else if (arr[i] == max)
nMax++;
}
std::cout << nMax;
delete[] arr;
return 0;
}
- 24.12.2015 17:59
- thumb_up 23
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.