Вопрос по информатике:
Как в C++ написать программу, чтобы она спрашивала твоё имя, а затем здоровалась с тобой. Я пишу, вроде всё правильно делаю, но программа выдает: "Hello, 0", чтобы я не вводила.
#include ;
using namespace std;
int main() {
int name;
cout << "What is your name?";
cin >> name;
cout << "Hello," << name<< endl;
return 0;
}
- 09.03.2015 17:09
- Информатика
- remove_red_eye 18936
- thumb_up 32
Ответы и объяснения 2
1) Ты забыл подключить библиотеку (надо было наприсать
#include )
2) int - тип целочисленных переменных - они могут принимать лишь значения, что не удивительно, целых чисел. Для твоей цели необходимо использовать строковую переменную, в C++ - это string (Для ее использования необходимо ее подключить - #include )
Итого
#include
#include
using namespace std;
int main() {
string name;
cout << "What is your name?";
cin >> name;
cout << "Hello, " << name<< endl;
return 0;
}
- 01.01.1970 00:00
- thumb_up 23
- 01.01.1970 00:00
- thumb_up 8
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.