Вопрос по информатике:
Напишите программу для паскаля! Дано натуральное число! Найти число, получаемое удалением из исходного числа всех цифр а.
- 12.08.2015 12:39
- Информатика
- remove_red_eye 4573
- thumb_up 34
Ответы и объяснения 1
1. "Школьное" решение
// PascalABC.Net 3.0, сборка 1066
var
s,s1:string;
i:integer;
a:char;
begin
Write('Введите натуральное число любой длины :'); Readln(s);
Write('Введите цифру, которую надо удалить: '); Readln(a);
s1:='';
for i:=1 to Length(s) do
if s[i]a then s1:=s1+s[i];
Writeln('Результат: ',s1)
end.
Тестовый прогон:
Введите натуральное число любой длины :3141592653589793
Введите цифру, которую надо удалить: 5
Результат: 3141926389793
2. Современное решение (так в школе почему-то не учат)
// PascalABC.Net 3.0, сборка 1066
begin
var s:=ReadString('Введите натуральное число любой длины :');
var a:=ReadChar('Введите цифру, которую надо удалить: ');
Write('Результат: ',s.Replace(a,''));
end.
- 13.08.2015 01:56
- thumb_up 20
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.