Вопрос по информатике:
Написать программу с использованием оператора while в результате работы которой осуществляется ввод чисел и подсчёт количества введённых положительных и отрицательных чисел и их сумма. Ввод осуществляется до тех пор пока не будет введён ноль
- 22.08.2016 00:48
- Информатика
- remove_red_eye 6469
- thumb_up 8
Ответы и объяснения 1
var n, k1, k2: integer;
begin
k1:=0;
k2:=0;
while 0 do
begin
write (‘Введите целое число>>’);
readln (n);
if n>0 then k1:=k1+1;
if n<0 then k2:=k2+1;
end;
writeln (‘Введено:’) ;
writeln (‘положительных чисел — ‘, k1);
writeln (‘отрицательных чисел — ‘, k2)
end.
- 22.08.2016 10:24
- thumb_up 15
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.