Вопрос по информатике:
Задание .На плоскости заданы своими координатами п точек. Составить программу, определяющую, между какими из пар точек самое большое расстояние. Указание. Координаты точек занести в массив......................................................................Реализовать в С++
#include "stdafx.h"
#include
using namespace std;
void Zadanie_1(int *a, int *b,int *c,int *d, int n) {
float *d =new float[n];
for (int i = 0; i < n; i++) {
for (int j=i+1;j<n;j++)
d[i] = sqrt((a[i] - c[i])* (a[i] - c[i]) + (b[i] - d[i])*(b[i] - d[i]));
cout << d[i] << endl;
}
}
int main() {
setlocale(LC_ALL, "Russian");
//1//
int n;//точек сколько, x-y- точки
cout << "Сколько точек" << endl;
cin >> n;
cout << "Введите координаты точек,в порядке x1,y1,x2,y2" << endl;
int *A = new int[n];//x1
int *B = new int[n];//y1
int *C = new int[n];//x2
int *D = new int[n];//y2
for (int i = 0; i < n; i++) {
cin >> A[i] >> B[i]>>C[i]>>D[i];
Zadanie_1(A,B,C,D,n);
}
return 0;
}
высветилась ошибка в функции(переопределение оператора d),может можно как-то по другому?
- 21.09.2018 13:14
- Информатика
- remove_red_eye 4423
- thumb_up 25
Ответы и объяснения 1
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.