Вопрос по информатике:
Написать программу которая будет вводить на экран максимальный элемент любого целочисленного массива
- 11.08.2018 10:48
- Информатика
- remove_red_eye 8499
- thumb_up 66
Ответы и объяснения 1
Если паскаль, то -
const n:=100; //в массиве пусть будет 100 элементов
var tarray:array[1..n] of integer;
max:integer;
i:=byte;
begin
{тут заполнение массива}
max:=tarray[1]; //думаем что максимум - это первый элемент
for i:=1 to n do
if max > tarray[i]
then max:=tarray[i];//если встречаем элемент больше максимального - то он -новый максимальный
write('Максимальный элемент - ', max);
end.
- 12.08.2018 18:49
- thumb_up 42
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.