Вопрос по информатике:
Дано натуральное число n. Напечатайте все n-значные нечетные натуральные числа в порядке убывания.
Входные данные
Вводится натуральное число.
Выходные данные
Выведите ответ на задачу.
решение через цикл for
на C++
- 17.09.2018 09:24
- Информатика
- remove_red_eye 9624
- thumb_up 37
Ответы и объяснения 1
#include
using namespace std;
int main() {
int n, from, to; // n - количество символов, from - от, to - до какого будем выводить
cin >> n; // вводим n
from = pow(10, n)-1; // а в степень n, верхняя граница
to = pow(10, n-1); // b в степень n-1, нижняя граница
for (int i = from; i >= to; i--) { //проходим по всему числовому отрезку
if (i%2==1) { // если число нечётное
cout << "\n" << i; // выводим его
}
}
return 0;
}
- 19.09.2018 00:17
- thumb_up 9
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.