Вопрос по информатике:
Пользователь вводит положительное целое число , не превышающее 10^9, нужно написать программу , которая выводит на экран сумму цифр этого числа, меньших 7. если в числе нет цифр , меньших 7, требуется на экран вывести 0
- 18.03.2016 19:00
- Информатика
- remove_red_eye 2648
- thumb_up 40
Ответы и объяснения 2
Program n1;
var n,k,s:real;
i:integer;
begin
readln(n);
if (n0) then
begin
writeln('число=',n);
if n>=6 then
begin
k:=0;
s:=0;
while k<7 do
begin
s:=s+k;
k:=k+1;
end;
writeln('сумма цифр=',s);
end else
writeln('0');
end;
end.
- 20.03.2016 00:33
- thumb_up 3
Var
n, sum: integer;
begin
read(n);
while n > 0 do
begin
if n mod 10 < 7 then
sum := sum + n mod 10;
n := n div 10
end;
writeln(sum);
end.
- 20.03.2016 01:01
- thumb_up 26
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.