Вопрос по информатике:
НА ПАСКАЛЬ ABC БЕЗ ВСЯКИХ СУППЕР ПУППЕР ВЕРСИЙ (ПОЛНОСТЬЮ )(30БАЛЛОВ)
Задача:
Найти количество четных цифр натурального числа.
Формат ввода:
На вход подается натуральное, не превосходящее 30000.
Формат вывода:
Целое число.
Пример входных данных
321
Пример выходных данных
1
- 14.10.2015 10:09
- Информатика
- remove_red_eye 8771
- thumb_up 47
Ответы и объяснения 2
begin
for a>0 to a=0 do
if (a mod 10) mod 2 =0 then
a:= a div 10;
c:=c+1
else
a:= a div 10;
writeln(c);
end.
- 15.10.2015 15:38
- thumb_up 28
begin
readln(a);
k:=0;
while a>0 do
begin
if a mod 2=0 then k:=k+1;
a:=a div 10;
end;
writeln(k);
end.
Пример:
321
1
- 17.10.2015 00:38
- thumb_up 4
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.