Вопрос по информатике:
Написать программу в ПАСКАЛЕ которая будет с помощью массива записывать числа введенные пользователем ⇒ оставлять только те, которые кратны 8(!)⇒ считать их среднее арифметическое. Максимальное число чисел - 100. Ввод чисел заканчивается числом 0.
- 12.08.2015 07:36
- Информатика
- remove_red_eye 3044
- thumb_up 20
Ответы и объяснения 1
const n=100;
var a: array [1..n] of integer;
i,k,sum,temp: integer;
begin
sum:=0;
k:=0;
for i:=1 to n do
begin
write('введите ',i,' элемент: ');
readln(temp);
if temp=0 then break;
if temp mod 8=0 then
begin
a[i]:=temp;
k:=k+1;
sum:=sum+a[i];
end;
end;
writeln('ср. ариф: ',sum/k);
end.
- 13.08.2015 21:32
- thumb_up 33
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.