Вопрос по информатике:
Срочно!!! Написать три программы на паскале.
1) Составить программу для вычисления площади, периметра и длины диагонали.
2)Составить программу для нахождения суммы, разности, произведения, частности введенные с клавиатуры.
3) Дано: треугольник ABC произвольный. Составить программу для вычисления его площади.
- 06.03.2018 08:27
- Информатика
- remove_red_eye 18501
- thumb_up 18
Ответы и объяснения 2
program calc;
var a, b, c: real;
var d: integer;
begin write('Введите числа (Внимание, если вы хотите произвести вычитание/деление, то введите уменьшаемое/делимое число первым.'); readln(a, b); write('Введите код операции. 1-сложение. 2-вычитание. 3-умножение. 4-деление.'); readln(d); case d of 1: c := a + b; 2: c := a - b; 3: c := a * b; 4: c := a / b; else writeln('Ошибка'); end; writeln('Ответ:', c);end.
- 08.03.2018 00:52
- thumb_up 7
// Внимание! Если программа не работает, обновите версию!
begin
var (a,b):=ReadReal2('Укажите длины сторон прямоугольника:');
Writeln('Площадь=',a*b,', периметр=',2*(a+b),
', диагональ=',Sqrt(a*a+b*b):0:5)
end.
Пример
Укажите длины сторон прямоугольника: 13.6 8.4
Площадь=114.24, периметр=44, диагональ=15.98499
begin
var (a,b):=ReadReal2('Введите a и b:');
Writeln('a+b=',a+b,', a*b=',a*b,', a/b=',a/b)
end.
Пример
Введите a и b: 134.23 -15.7
a+b=118.53, a*b=-2107.411, a/b=-8.54968152866242
begin
var (a,b,c):=ReadReal3('Введите стороны треугольника:');
var p:=(a+b+c)/2;
Writeln('S=',Sqrt(p*(p-a)*(p-b)*(p-c)):0:3)
end.
Пример
Введите стороны треугольника: 13 8 11.3
S=44.843
- 08.03.2018 15:34
- thumb_up 21
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.