Вопрос по информатике:
Паскаль
Составить программу, которая выводит меню и при нажатии вводе цифры вычисляет соответствующее
выражение:
1 - y= (a+b)^2
2 - y= a^2-b^2
3 - y= 1/(a+b)
- 26.11.2015 17:21
- Информатика
- remove_red_eye 8906
- thumb_up 22
Ответы и объяснения 1
Var i,y,a,b: single;
begin
writeln('Выберите действие: 1)y=(a+b)^2; 2)y=a^2-b^2; 3)y=1/(a+b)');
read(i);
if i=1 then begin
writeln('Введите a и b');
read(a,b);
write('y=',(a+b)*(a+b));
end
else begin
if i=2 then begin
writeln('Введите a и b');
read(a,b);
write('y=',(a*a)-(b*b));
end
else begin
if i=3 then begin
writeln('Введите a и b');
read(a,b);
write('y=',1/(a+b));
end;
end;
end;
end.
- 27.11.2015 13:14
- thumb_up 27
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.