Вопрос по информатике:
Составить программу в массиве с N числами поменять местами максимальное и минимальное значения
- 25.03.2017 19:07
- Информатика
- remove_red_eye 1352
- thumb_up 23
Ответы и объяснения 1
Программа может выглядеть так:
uses Crt;
const n=10;
type Mas=array [1..n] of integer;
var A: Mas;
i, temp, MinInd, MaxInd, Max, Min: integer;
begin
ClrScr;
Randomize;
for i:=1 to n do
begin
A[i]:=10+random(90);
Write (A[i]:5);
end;
WriteLn;
Max:=A[1]; MaxInd:=1;
Min:=A[1]; MinInd:=1;
for i:=2 to n do
begin
if A[i]
Min:=A[i];
MinInd:=i;
end
else
if A[i]>Max then
begin
Max:=A[i];
MaxInd:=i;
end;
end;
temp:=A[MaxInd];
A[MaxInd]:=A[MinInd];
A[MinInd]:=temp;
WriteLn;WriteLn;
for i:=1 to n do
Write (A[i]:5);
WriteLn;
ReadLn;
end.
- 27.03.2017 00:09
- thumb_up 7
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.