Вопрос по информатике:
Процедура целочисленного деления двух целых чисел (входные параметры: a,b- числа; выходной параметр- целое частное a/b).
Функция целочисленного деления двух целых чисел (выходные параметры: a,b- числа; возвращаемое значение - целое частное a/b). Написать программу в PascalABC.NET.
- 25.03.2017 18:44
- Информатика
- remove_red_eye 1216
- thumb_up 40
Ответы и объяснения 1
procedure dp(a,b: integer);
begin
writeln(a div b);
end;
функция:
function df(a,b: integer): integer;
begin
df:=a div b;
end;
программа с процедурой:
Program n1;
var x,y: integer;
procedure dp(a,b: integer);
begin
writeln(a div b);
end;
begin
readln(x,y);
dp(x,y);
end.
программа с функцией:
Program n1;
var x,y: integer;
function df(a,b: integer): integer;
begin
df:=a div b;
end;
begin
readln(x,y);
writeln(df(x,y));
end.
- 26.03.2017 01:05
- thumb_up 5
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.