Вопрос по информатике:
Составить программу которая будет вычислять значение выражения у = cosx + cosx^2 + cosx^3 + ... + cosx^n, используя процедуру вычисляющую x в n степени
- 26.11.2015 17:38
- Информатика
- remove_red_eye 8105
- thumb_up 41
Ответы и объяснения 1
// Возводит действилельное число x в целую степень n
Procedure Pow(Const X:real; Const n:integer; Var St:real);
Var i:integer;
Begin
St:=1;
For i:= 1 to n do
St:=St*x;
End;
Var
x,y,St:real;
n:integer;
Begin
y:=0;
Write('x = ');ReadLn(x);
Write('n = ');ReadLn(n);
For n:= 1 to n do
Begin
Pow(x,n,St);
y:=y+Cos(St);
End;
WriteLn('y = ',y);
End.
Функцией:
// Возводит действилельное число x в целую степень n
Function Pow(Const X:real; Const n:integer):real;
Var i:integer;
Begin
result:=1;
For i:= 1 to n do
result:=result*x;
End;
Var
x,y:real;
n:integer;
Begin
y:=0;
Write('x = ');ReadLn(x);
Write('n = ');ReadLn(n);
For n:= 1 to n do
y:=y+Cos(Pow(x,n));
WriteLn('y = ',y);
End.
Циклом:
Var
x,y,St:real;
n:integer;
Begin
y:=0;
Write('x = ');ReadLn(x);
Write('n = ');ReadLn(n);
St:=1;
For n:= 1 to n do
Begin
St:=St*x;
y:=y+Cos(St);
End;
WriteLn('y = ',y);
End.
- 27.11.2015 00:45
- thumb_up 15
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.