Вопрос по информатике:
Ниже записана программа. Получив на вход число x , эта программа печатает два числа, L и M. Укажите наибольшее из таких чисел x, при вводе которых алгоритм печатает сначала 3, а потом 7.
var x, L, M: integer;
begin
readln(x);
L:=0; M:=0;
while x > 0 do begin
L:= L + 1;
if x mod 2 = 1 then
M:= M + (x mod 10) div 2;
x:= x div 10;
end;
writeln(L); write(M);
end.
- 24.08.2018 08:18
- Информатика
- remove_red_eye 17690
- thumb_up 26
Ответы и объяснения 1
в M=7 - сумма целых частей двух нечётных цифр, делённых на два
7=4+3; цифры (нечётные) 9 и 7
одна из цифр числа должна быть чётной, мах чётная цифра это 8
из цифр 9, 7, 8 составляем наибольшее число, оно = 987
ответ 987
- 25.08.2018 00:44
- thumb_up 27
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.