Вопрос по информатике:
Добрый вечер.
Пожалуйста, помогите написать программу (на Pascal) для решения квадратного уравнения.
- 01.06.2016 15:41
- Информатика
- remove_red_eye 772
- thumb_up 23
Ответы и объяснения 1
Var a,b,c,d,x1,x2:real;
begin
read(a,b,c);
d:=sqr(b)-4*a*c;
if(d>0)then begin
x1:=(-b+sqrt(d))/(2*a);
x2:=(-b-sqrt(d))/(2*a);
writeln('x1=',x1:3:5,' x2=',x2:3:5);
end else if(d=0)then begin x1:=-b/(2*a); writeln(x1:5);end
else writeln('Нет корней. Дискриминант меньше 0');
end.
- 02.06.2016 17:21
- thumb_up 47
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.