Вопрос по информатике:
Составить программу в паскале
Массив задан датчиком случайных чисел на интервале [-37, 66]. Найти наибольший и наименьший элементы и их номера. Размер массива произвольный, но не больше 100
- 17.06.2018 22:06
- Информатика
- remove_red_eye 17653
- thumb_up 24
Ответы и объяснения 1
// Внимание! Если программа не работает, обновите версию!
begin
var a:=ArrRandom(ReadInteger('n='),-37,66); a.Println;
var (imin,imax):=(a.IndexMin,a.IndexMax);
Writeln('Минимальный элемент №',imin+1,' равен ',a[imin]);
Writeln('Максимальный элемент №',imax+1,' равен ',a[imax]);
end.
Пример
n= 17
17 21 49 -2 49 30 -3 39 11 20 65 -28 10 14 -30 11 -1
Минимальный элемент №15 равен -30
Максимальный элемент №11 равен 65
- 18.06.2018 00:35
- thumb_up 30
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.