Вопрос по информатике:
Необходимо составить программу с двумерным массивом. Для заполнения данного массива нужно использовать генератор случайных чисел.
I - отвечает за номер строки.
J - отвечает за номер столбца.
Заполненные массивы должны выглядеть так:
при const n=3
1 2 1
2 3 2
1 2 1
при const n=5
1 2 3 2 1
2 1 2 1 2
3 2 1 2 3
2 1 2 1 2
1 2 3 2 1
Желательно, составить блок-схему.
- 03.04.2016 15:11
- Информатика
- remove_red_eye 11140
- thumb_up 18
Ответы и объяснения 1
В программе две константы: n и m. n отвечает за размер массива, m за максимальное значение случайного числа от 0 до на 1 меньше чем само m.
Program Zadacha;
Const n = 5; m = 5;
Var a: Array [1..n, 1..n] of Integer;
i, j: Integer;
Begin
Randomize;
For i := 1 To n Do
For j := 1 To n Do
a[i, j] := Random(m);
WriteLn('Результат:');
For i := 1 To n Do
Begin
For j := 1 To n Do
Write(a[i, j], ' ');
WriteLn;
End;
ReadLn;
End.
- 04.04.2016 00:32
- thumb_up 34
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.