Вопрос по информатике:
Составьте программу, по которой компьютер десять раз запросит ввод любых чисел и в результате выведет среднее арифметическое значение введенных чисел (массив не использовать). Сделайте три варианта программы используя операторы цикла While, Repeat и For.
- 11.08.2018 06:51
- Информатика
- remove_red_eye 10143
- thumb_up 35
Ответы и объяснения 1
var
a,b,c,i:integer;
begin
i:=0;
b:=0;
writeln('Write 10 number:');
while i<10 do
begin
read(a);
b:=b+a;
i:=i+1;
end;
writeln('Average: ',b/10:0:0);
readln
end.
- 12.08.2018 16:50
- thumb_up 19
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.