Вопрос по информатике:
Помогите пожалуйста составить программу!!!!!!!!!!!!!!
Известный пират Флинт положил некоторую сумму S в банк по 3% годовых. Выведите на экран, через сколько лет сумма превысит 1,5S. Начальное значение S вводится с клавиатуры.
- 04.04.2017 07:05
- Информатика
- remove_red_eye 12375
- thumb_up 18
Ответы и объяснения 1
Решение в С++:
#include
using namespace std;int main(void)
{
setlocale(LC_ALL, "Russian");
double S, x;
cout << "Введите сумму S : ";
cin >> S;
x = 3. * S / 100.;
cout<<"Годовой доход составляет: "<< x << endl;
int i;
i = 1.5*S / x;
if (i*x==1.5*S)
{ i++;
cout << "Через " << i << " год доход превысит 1.5*S и составит: "<< i * x<
cout << "Через " << i << " лет доход превысит 1.5*S и составит: " << i * x << endl;
system("pause");
return 0;
}
- 05.04.2017 00:23
- thumb_up 46
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.