Вопрос по информатике:
Дан порядковый номер дня года (отсчет идет с 1-го января). Требуется вывести номер дня недели этого дня, если 1 января — понедельник. (Запрещено использовать команду if) Формат входных данных Вводится номер дня года — целое число k (1≤k≤365). Формат выходных данных Выведите номер дня недели для данного дня года (понедельник — 1, вторник — 2, ..., воскресенье — 7).На С++
- 21.08.2015 23:56
- Информатика
- remove_red_eye 6575
- thumb_up 15
Ответы и объяснения 1
using namespace std;
int main()
{
int k, n;
cin >> k;
n = (k-1) % 7 + 1;
cout << n <
}
Пример:
14
7
- 22.08.2015 19:35
- thumb_up 47
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.