Вопрос по информатике:
СРОЧНО, ПОМОГИТЕ ПОЖАЛУЙСТа
составить программу в паскале...
Дано А(N,M). Найти номер строки, где находится первый элемент, кратный 5. Поменять местами последнюю и найденную строку.
- 26.12.2016 13:48
- Информатика
- remove_red_eye 15221
- thumb_up 46
Ответы и объяснения 1
// Внимание! Если программа не работает, обновите версию!
begin
Write('Количество строк и столбцов в массиве:');
var (n,m):=ReadInteger2;
Writeln('*** Исходный массив [',n,',',m,'] ***');
var a:=MatrRandom(n,m,-99,99);
a.Println(4); Writeln(4*a.ColCount*'-');
var t:=a.ElementsWithIndexes.Where(x->x[0] mod 5=0).Take(1);
a.SwapRows((t.First)[1],n-1);
Writeln('*** Результирующий массив ***'); a.Println(4)
end.
Пример
Количество строк и столбцов в массиве:4 5
*** Исходный массив [4,5] ***
-32 -12 94 -28 -42
-15 29 80 28 -69
-5 68 63 -12 22
59 84 65 14 -86
--------------------
*** Результирующий массив ***
-32 -12 94 -28 -42
59 84 65 14 -86
-5 68 63 -12 22
-15 29 80 28 -69
- 27.12.2016 10:06
- thumb_up 23
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.