Вопрос по информатике:
Решить задачи:
Разработать схему алгоритма и написать программу
a) Вычисления среднего арифметического четырех чисел;
b) Вывода вашего роста , возраста и веса на экран4
c) Вычисление значения корней квадратного уравнения
Выполнить трассировку программ.
- 26.12.2016 13:42
- Информатика
- remove_red_eye 1227
- thumb_up 20
Ответы и объяснения 2
Program R_BP;Uses crt;Var r,a,b,c,d:real;beginclrscr;write( 'Введите через "Enter" 4 числа ');read(a,b,c,d);r:=(a+b+c+d)/4;writeln('Ответ ',r);end.
2 задача Program R_BP;Uses crt;Var r,a,b,c,d:real;beginclrscr;write( 'Введите ваш рост');read(a);writeln('Введите ваш вес ');readln(R);writeln('Ваш вес = ',r,' ваш ростс = ',a);end;
var a,b,c,d:integer; x:real; begin write('Введите a,b,c: '); readln(a,b,c); //Дискриминант d:=sqr(b)-4*a*c; if d<0 Then writeln('Не имеет смысла') else if d=0 Then begin x:=-b/(2*a); writeln(x); end else begin x:= (-b + sqrt(D))/(2*a); writeln(x); x:= (-b - sqrt(D))/(2*a); writeln(x); end; end.
- 27.12.2016 00:18
- thumb_up 8
A)Pascal
Var
a,b,c,d, average: real;
Begin
Writeln('Введите 4 числа, каждый ввод закончить нажатием кнопки Enter');
readln(a,b,c,d);
Average:=(a+b+c+d)/4;
Writeln('Среднее Арифметическое 4-х чисел = ',Average);
end.
b)
var
Age,High:integer;
Ves:real;
begin
Writeln('Введите Возраст');
readln(age);
Writeln('Введите Рост);
readln(high);
Writeln('Введите вес);
readln(ves);
Writeln('Ваш возраст ',age,'Ваш Рост ', high, ' Ваш Вес ',ves);
end.
C)
var
n:integer;
begin
Writeln('Введите Число N');
readln(n);
n:=n*n;
Writeln('Квадратный корень равен= ',n);
end.
- 28.12.2016 05:09
- thumb_up 29
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.