Вопрос по информатике:
Напишите программу, которая получает три числа – рост трёх спортсменов, и выводит сообщение "on growth!", если числа введены по возрастанию, или сообщение 'dont on growth!', если они введены в другом порядке
Например:
Входные данные
165 170 172
Выходные данные
on growth!
Например:
Входные данные
175 170 172
Выходные данные
dont on growth!
С++
Только использовать всякие if ,for,while,scanf,printf,#include <stdio.h>
#include <conio.h>
#include <math.h>,main,getch, max,min, математические действия и остаток от деления. Если это потребуется.
- 24.08.2018 06:15
- Информатика
- remove_red_eye 10290
- thumb_up 13
Ответы и объяснения 2
#include "stdafx.h"
#include
int main()
{
int n;
int save_n=0;
bool b = true;
for (int i = 0; i < 3; i++)
{
std::cin >> n;
if (save_n>0&&save_n >= n&&b)
b = false;
save_n = n;
}
if (b)
std::cout << "on growth!"<<"\n";
else
std::cout << "dont on growth!"<<"\n";
system("pause");
return 0;
}
- 25.08.2018 18:20
- thumb_up 10
#include
#include
int main()
{
setlocale(LC_ALL, "RUS");
int g[3];
for (int i = 0; i < 3; i++)
{
printf("Введите рост %d спортсмена >> ", i+1);
scanf("%d", &g[i]);
}
if (g[0] < g[1] && g[1] < g[2])
printf("on growth");
else
printf("don't on growth");
system("pause");
}
- 26.08.2018 17:08
- thumb_up 25
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.