Вопрос по информатике:
Напишите программу паскаль: С клавиатуры вводится число от 0 до 1000 включительно. Каждая цифра не превосходит 6. Найти сумму промежуточных значений между наибольшей и наименьшей цифрами в числе?
- 24.03.2018 01:09
- Информатика
- remove_red_eye 15818
- thumb_up 38
Ответы и объяснения 1
program num32;var
nums, i, min, max, a, i2, i3, sum: integer;begin
min := 7;
max := 0;
sum := 0;
readln(nums);
while nums 0 do
begin
if (((nums mod 10) > max)) then begin
max := nums mod 10;
end;
if (((nums mod 10) < min)) then begin
min := nums mod 10;
end;
nums := nums div 10;
end;
if (min > max) then begin
for i2 := max to min do
sum := sum + i2;
end;
if (max > min) then begin
for i2 := min to max do
sum := sum + i2;
end;
writeln(sum);
end.
- 25.03.2018 12:51
- thumb_up 16
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.