Вопрос по информатике:
Написать программу на Pascal ABC. Дано
предложение. Вывести строку в обратном порядке. Вывести столбиком все его буквы
"и", стоящие на четных местах.
Трудности с пониманием предмета? Готовишься к экзаменам, ОГЭ или ЕГЭ?
Воспользуйся формой подбора репетитора и занимайся онлайн. Пробный урок - бесплатно!
- 11.05.2017 02:05
- Информатика
- remove_red_eye 10364
- thumb_up 20
Ответы и объяснения 1
Var
str : string;
i, count : integer;
begin
{часть 1 - обратный порядок}
write('Введите строку: ');
readln(str);
write('Результат: ');
for i := length(str) downto 1 do
write(str[i]);
{часть 2 - считаем "и"}
count := 0;
for i := 1 to length(str) do
if (str[i] = 'и') and (i mod 2 = 0) then
count := count + 1;
writeln; {переходим на следующую строку}
for i := 1 to count do
writeln('и');
end.
- 12.05.2017 08:54
- thumb_up 11
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.