Вопрос по информатике:
DevC++ помогите плиз.
Даны три целых числа a, b и с
Напишите программу, которая находит количество всех целых чисел от a до b, которые при целочисленном делении на с дадут остаток больший 4
Входные данные:
В первой строке вводятся три целых числа a, b и с (a<=b, a,b не больше 100 по модулю, 0<=с<=9)
Выходные данные:
Программа должна вывести одно число - количество всех целых чисел от a до b, которые при целочисленном делении на с дадут остаток больший 4
Пример:
Ввод 1 10 9
Вывод: 4
Выполните пожалуйста с #include conio.h и #include stdio.h
Трудности с пониманием предмета? Готовишься к экзаменам, ОГЭ или ЕГЭ?
Воспользуйся формой подбора репетитора и занимайся онлайн. Пробный урок - бесплатно!
- 11.05.2017 02:41
- Информатика
- remove_red_eye 19407
- thumb_up 21
Ответы и объяснения 1
#include
#include
#include
int main(int argc, char** argv) {
int a,b,c,k = 0;
scanf("%d",&a);
scanf("%d",&b);
scanf("%d",&c);
for (int i=a;i<=b;i++)
{
if(i%c>4) k++;
}
printf("/%10d/",k);
system ("pause");
return 0;
}
- 12.05.2017 20:20
- thumb_up 36
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.