Вопрос по информатике:
Помогите!!!!
Напишите программу,которая в последовательности натуральных чисел определяет количество трехзначных чисел,кратных 4.Программа получает на вход натуральные числа,количество введенных чисел,неизвестно,последовательность чисел заканчивается числом 0 (0-признак окончания ввода,не входит в последовательность).Количество чисел не превышает 1000.Введенные числа не превышают 30000.Программа должна вывести одно число:количество трехзначных чисел,кратных 4.
(Паскаль)
- 16.12.2016 22:39
- Информатика
- remove_red_eye 10341
- thumb_up 25
Ответы и объяснения 2
// Внимание! Если программа не работает, обновите версию!
begin
Write(ReadSeqIntegerWhile(k->k0).
Where(k->(k>99) and (k<1000) and (k mod 4=0)).Count)
end.
Пример
45 244 1043 463 500 241 18 44 0
2
- 17.12.2016 13:07
- thumb_up 20
Begin
k:=0;
Repeat
Read(A);
if (A>99)and(A<1000)and(A mod 4 = 0) then k:=k+1
Until A = 0;
WriteLn(k);
End.
- 18.12.2016 03:02
- thumb_up 20
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.