Вопрос по информатике:
Получить квадратную матрицу порядка n:
k 0
n-1 n
n-2 n-1 n
.... ..... ....
1 2 3...n
Может кто знает как написать программу в Паскале?
- 26.12.2015 23:38
- Информатика
- remove_red_eye 15761
- thumb_up 16
Ответы и объяснения 1
Const n=6;
var a:array[1..n,1..n] of integer;
i,j:integer;
begin
for i:=1 to n do
for j:=1 to i do a[i,j]:=n-i+j;
for i:=1 to n do
begin
for j:=1 to n do write(a[i,j]:3);
writeln;
end;
end.
Пример:
6 0 0 0 0 0
5 6 0 0 0 0
4 5 6 0 0 0
3 4 5 6 0 0
2 3 4 5 6 0
1 2 3 4 5 6
- 27.12.2015 02:35
- thumb_up 44
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.