Вопрос по информатике:
составить программу в паскале! пожалуйста!!! СРОЧНО! 9 класс! Написать программу, которая на ввод времени суток выводит соответствующее пожелание доброго утра, доброго дня, доброго вечера или спокойной ночи.
- 04.05.2016 00:34
- Информатика
- remove_red_eye 15723
- thumb_up 22
Ответы и объяснения 2
var
time: 0..23;
begin
writeln('Введите текущее время в часах');
readln(time);
if time in [0..6] then writeln('Спокойной ночи!');
if time in [7..12] then writeln('Доброго утра!');
if time in [13..18] then writeln('Доброго дня!');
if time in [19..23] then writeln('Доброго вечера!');
end.
Пояснение: в этой программе используются множества. Если время в часах входит в множество чисел, указанных в квадратных скобках, то программа пишет соответствующее сообщение. Например: if time in [0..6] означает: если введенное время входит в промежуток от 0 до 6.
- 05.05.2016 19:30
- thumb_up 32
var
hour:integer;
begin
write('Который час? '); readln(hour);
case hour of
6..11: writeln('Доброе утро');
12..15:writeln('Добрый день');
16..21: writeln('Добпый вечер');
22..24, 0..5: writeln('Доброй ночи');
else
writeln('В сутках только 24 часа');
end;
end.
//через if
var Hour:integer;
begin
writeln('Введите время');
readln(Hour) ;
if Hour <= 12 then
begin
writeln('Добрго утра');
end;
if (Hour > 12) and (Hour < 20) then
begin
writeln('Доброго дня');
end;
if (Hour >= 20) and (Hour <= 24) then
begin
writeln('Добрый вечер');
end;
if Hour > 24 then
begin
writeln('Не многовато часиков то ?');
end;
end.
- 06.05.2016 08:43
- thumb_up 28
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.