Вопрос по информатике:
1. Написать программу, которая подсчитывает количество элементов, четных и оканчивающихся на 6, в массиве целых чисел. Количество элементов массива равно N. Массив заполнить случайными числами в интервале [20,80). Если таких чисел нет, напечатать «Нет».
2. Написать программу, которая подсчитывает количество пар элементов в массиве, в которых каждый элемент равен второму в паре. В массиве 10 элементов, массив заполняется с помощью случайных чисел из интервала (0, 100).
- 27.12.2015 00:19
- Информатика
- remove_red_eye 4386
- thumb_up 27
Ответы и объяснения 1
// PascalABC.NET 3.3, сборка 1634 от 14.02.2018
// Внимание! Если программа не работает, обновите версию!
begin
var a:=ArrRandom(ReadInteger('n='),20,80); a.Println;
var k:=a.Where(t->t mod 10=6).Count;
if k>0 then Writeln(k)
else Writeln('Нет')
end.
Пример
n= 15
47 53 73 26 75 64 70 32 27 80 29 53 20 62 66
2
2. Достаточно много раз нужно запускать задачу, чтобы суметь получить случайную последовательность с парой одинаковых соседних элементов...
// PascalABC.NET 3.3, сборка 1634 от 14.02.2018
// Внимание! Если программа не работает, обновите версию!
begin
var a:=ArrRandom(10,0,100); a.Println;
var k:=a.Pairwise.Where(t->t[0]=t[1]).Count;
if k>0 then Writeln(k)
else Writeln('Нет')
end.
Пример
60 41 87 87 95 75 72 32 8 52
1
- 27.12.2015 22:53
- thumb_up 48
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.