Вопрос по информатике:
Ребат помогите составить программу пжл. Составьте программу, которая заполняет одномерный целочисленный массив из 50 элементов случайным образом в диапозоне от 1до 60, выводит массив на экран в строку, затем- четные элементы складывает, нечетные элементы перемножает, после чеговыводит сумму и произведение. блок схему к ней, если можно, заранее спс.
- 24.08.2018 06:04
- Информатика
- remove_red_eye 6191
- thumb_up 32
Ответы и объяснения 1
a: array[1..100] of integer;
i, n: integer;
sum, product, harmonic: real;
begin
n := 50;
writeln('Данные массива:');
for i := 1 to n do
begin
a[i] := random(60);
write(a[i], ' ');
end;
writeln();
{подсчет суммы и произведения и агригатов}
sum := 0;
product := 1;
for i := 1 to n do
if i mod 2 = 0 then
sum := sum + a[i]
else
product := product * a[i];
writeln('sum = ', sum);
writeln('product = ', product);
end.
- 25.08.2018 06:15
- thumb_up 15
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.