Вопрос по информатике:
Составьте программу решения следующей задачи:
С клавиатуры вводится двузначное число a. Найти сумму его цифр.
- 17.09.2018 11:49
- Информатика
- remove_red_eye 13186
- thumb_up 47
Ответы и объяснения 2
Uses crt;
var a: integer;
begin
clrscr;
write('a = ');
readln(a);
if ((abs(a)>9) and (a<100)) then
writeln('Sum = ', abs(a mod 10) + abs(a div 10))
else
writeln('Error');
end.
- 18.09.2018 22:57
- thumb_up 27
begin
write('a = ');
readln(a);
s:=(a div 10)+(a mod 10);
writeln('s = ',s);
end.
Пример:
a = 52
s = 7
- 19.09.2018 18:30
- thumb_up 25
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.