Вопрос по информатике:
Pascal. Составьте программу для определения принадлежности точки P с координатами (x, y) области, которая образована первой дугой синусоиды и осью Ох.
- 08.03.2018 22:07
- Информатика
- remove_red_eye 2182
- thumb_up 48
Ответы и объяснения 1
Точка с координатами (x, y) принадлежит области, если 0 <= x <= pi и 0 < y < sin(x), лежит на границе, если первое выполнено, и y = 0 или y = sin(x), а иначе не лежит в области.
Код (PascalABC.NET 3.2):
begin
var x, y: real;
readln(x, y);
if (0 <= x) and (x <= pi) then
if (0 < y) and (y < sin(x)) then
writeln('Внутри области')
else if (0 = y) or (y = sin(x)) then
writeln('На границе')
else
writeln('Не принадлежит')
else
writeln('Не принадлежит')
end.
- 09.03.2018 13:00
- thumb_up 44
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.