Вопрос по информатике:
Задачи нужно решить на языке Паскаль. Изучаем string.
1.Дана строка. Написать программу, выводящую сумму порядковых номеров заданного символа.
2.Дано предложение состоящее из английских заглавных букв. В предложении только одно слово в котором 3 буквы. Вам нужно написать программу которая найдет это слово и выведет его в файл.
- 06.03.2018 14:38
- Информатика
- remove_red_eye 4230
- thumb_up 38
Ответы и объяснения 1
Var
s:string;
c:char;
sum,i:integer;
begin
readln(s);
readln(c);
for i:=1 to length(s) do
if s[i]=c then sum+=i;
writeln(sum);
end.
Пример ввода:
konichiva
i
Пример вывода:
11
//2
Var
f:text;
s:string;
i:integer;
begin
readln(s);
var ars:=s.Split;
i:=0;
while ars[i].Length3 do
inc(i);
assign(f,'output.txt');
rewrite(f);
write(f,ars[i]);
close(f);
end.
Пример ввода:
ARK DRIVE FINISH
Пример вывода в файл output.txt:
ARK
- 07.03.2018 17:47
- thumb_up 42
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.