Вопрос по информатике:
ПОМОГИТЕ ПОЖАЛУЙСТА, ОЧЕНЬ СРОЧНО!! Написать программу с массивом случайных 5 чисел от -50 до 50, если больше нуля - то сложить их, если меньше нуля - вычесть. (сумма и разность)
- 08.01.2018 06:22
- Информатика
- remove_red_eye 6725
- thumb_up 21
Ответы и объяснения 2
const n=5;
var a:array[1..n] of integer;
i,s,r:integer;
begin
Randomize;
writeln('Массив A:');
for i:=1 to n do
begin
a[i]:=random(101)-50;
write(a[i]:4);
end;
writeln;
s:=0; r:=0;
for i:=1 to n do
if a[i]>0 then s:=s+a[i] else r:=r-a[i];
writeln('s = ',s,' r = ',r);
end.
Пример:
Массив A:
29 32 -48 -42 11
s = 72 r = 90
- 09.01.2018 12:01
- thumb_up 41
#include
#include
using namespace std;
int main() {
int a[5], p = 0, n = 0;
srand ( time(NULL) );
for (int i = 0 ; i < 5 ; i++) {
a[i]=rand()%100-50;
cout << a[i] << ' ';
if(a[i] > 0) p+=a[i];
else n-=a[i];
}
cout << endl << p << ' ' << n << endl;
}
- 01.01.1970 00:00
- thumb_up 46
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.