Вопрос по информатике:
Написать программу которая по номеру дня недели выдаст название дня и количество уроков в вашем классе .В Паскале .Ps уроков у нас 6 каждый день .кроме среды. в среду 7 уроков
- 20.06.2017 08:04
- Информатика
- remove_red_eye 15304
- thumb_up 29
Ответы и объяснения 2
Пронумеруем дни недели числами от 0 до 6 (0-Вс, 1-Пн, .. 6-Сб).
var
dow:0..6;
begin
Write('Введите номер дня недели (0-Вс, 6-сб): ');
Read(dow);
case dow of
0:Writeln('Воскресенье, выходной');
1:Writeln('Понедельник, 6 уроков');
2:Writeln('Вторник, 6 уроков');
3:Writeln('Среда, 7 уроков');
4:Writeln('Четверг, 6 уроков');
5:Writeln('Пятница, 6 уроков');
6:Writeln('Суббота, 6 уроков');
else Writeln('Введено неверное значение')
end
end.
Тестовое решение:
Введите номер дня недели (0-Вс, 6-сб): 5
Пятница, 6 уроков
- 21.06.2017 04:22
- thumb_up 10
Program al;
Var
x: integer;
BEGIN
Repeat
Write('VVedite cislo ot 1 äî 7: ');
Readln(x);
until x in [1..7];
Case x of
1: Writeln('Ponidelnik-6urokov');
2: writeln('Vtornik-6erokov');
3: writeln('Sreda-7urokov');
4: writeln('Cetverg-6urokov');
5: writeln('Piatnita-6urokov');
6: writeln('Subbota-6urokov');
7: writeln('Voskresenie-vihadnoy');
end;
Readln
END.
- 22.06.2017 06:39
- thumb_up 31
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.