Вопрос по информатике:
Напишите программу, которая в последовательности целых чисел определяет их сумму и количество четных чисел, кратных 5. Программа получает на вход целые числа, количество введенных чисел неизвестно, последовательность чисел заканчивается число 0(0-признак окончания ввода, не входит в последовательность СРОЧНО, ПОЖАЛУЙСТА, НА ПАСКАЛЕ. ОЧЕНЬ СРОЧНО
- 03.03.2017 11:32
- Информатика
- remove_red_eye 15623
- thumb_up 24
Ответы и объяснения 1
var i,k,sum:integer; a:array [1..1000] of integer;
begin
for i:=1 to 1000 do
begin;
readln(a[i]);
if a[i]=0 then break;
end;
k:=0;
sum:=0;
for i:=1 to 1000 do
begin;
sum:=sum+a[i];
if (a[i] mod 2=0) and (a[i] mod 5=0) and (a[i]0) then
k:=k+1;
end;
writeln('summa= ',sum);
writeln('kolichestvo=',k);
readln;
end.
- 04.03.2017 02:46
- thumb_up 14
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.