Вопрос по информатике:
Нужно написать программу на Паскале: В матрице размера M×N положительные элементы заменить единицей. Создание и вывод матриц оформить в виде процедур.
- 05.06.2018 16:21
- Информатика
- remove_red_eye 14727
- thumb_up 17
Ответы и объяснения 1
Внимание! Если программа не работает, обновите версию!
procedure MatrixCreate(m,n:integer; var A:array[,] of integer);
begin
A:=MatrRandom(m,n,-50,50);
end;
procedure MatrixOutput(A:array[,] of integer);
begin
A.Println(4)
end;
begin
var (m,n):=ReadInteger2('Количество строк и столбцов в матрице:');
var a:array[,] of integer;
MatrixCreate(m,n,a);
Writeln('*** Исходная матрица ***');
MatrixOutput(a);
a.Transform(t->t>0?1:t);
Writeln('*** Полученная матрица ***');
MatrixOutput(a);
end.
- 06.06.2018 13:56
- thumb_up 41
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.